Yoast error

The theme has some code in the header which helps for SEO if popular plugins are not installed. If you have the latest version of the theme though, popular plugins such as Yoast work, since the code which Yoast detects is not effectively on the site. The plugin doesn't know this, but i assure you 100% that  Yoast works even if you see that notice! Just dismiss it and continue with working on the theme.